Can't tell if New Subgenre request went through

I tried to request a new subgenre, and I have no idea if it went through or not. After I hit the Send Request button, the dialogue grayed out and the loading spinner spun and spun… And then it kicked me right back to the Request form, just the way it was before I hit the button. My wifi is flakey sometimes, so I tried it again, and it did the exact same thing.

Did it fail? Did it succeed? How am I supposed to know?

1 Like

Hi Arden,

The Content team is putting all of their energy into improving the platform, and they review all of the requests for new genres/subgenres. As with all questions, unfortunately sometimes the answer is no.

The best way to check if your request was approved, is to clear your browser cache and then try and add your sub genre again.

We recommend Google Chrome for the best experience.

Community Support Lead

Oh, to be clear, this is a UI issue.

The behavior of the request window was so uncommunicative that I don’t know if the request even went through. I expected a confirmation message or an error message after the spinner was done spinning.

Thanks for the tip, though.


I didn’t get any confirmation either. It would be nice to have that.