Tier Updates Are Slow

Hi! I’ve been working on updating my tiers and really struggling, because the responsiveness on the tiers page is very slow for me. If I type something in a text box, it usually appears around 1 character a second, and highlighting is slow, etc. When I save, it sometimes won’t save my updates, or reverts to updates from two or three saves ago, too. It’s been the same for me on Chrome and Safari on an older Mac. Is this a known thing, or do I need to do anything to make it go more smoothly? Thanks!


So I actually had this happen to me as well. Bunch of things play into this.

  1. Try just updating one tier at a time, some (like me) have had it only save the tier you were clicked in, wiping the other info.
  2. bookmark your author page, it will force your browser to save more info locally, avoiding internet issues. This has helped several people.
  3. triple check you tech! Make sure your device is all up to date in whatever your using, then give it an off/on to make it fresh.
  4. Ream is constantly doing the little things all the time to increase optimization, which means clearing your browser cache often helps a lot, improves the connection to servers

Apart from that, give it time, Ream is always chasing hiccups that pop up like this. With time it will just get better!

1 Like

Can you reach out to info@reamstories.com so we can look into this issue further with you? I would like to hop on a call with you and see this issue in detail so our tech team can fix it. Email us and we can figure out a time that works best for you :slight_smile:

1 Like

I’m having similiar issue. I deleted my original tiers last week to shift to managed, which I’ve been told this morning is done. But when I go to create a new tier, it doesn’t seem to save. I add it, then click save, and nothing changes on the edit page but when I look at the “view” page the tier isn’t there. If I do a hard refresh of the “edit” page my new tier just disappears, despite me clicking “save” before I do that (I’ve recreated the effect about three times now).

Email us at info@reamstories.com so we can help. I will need to hop on a call with you so we can debug this. Let me know what times work for you and we can fix this :). So sorry about this problem!

1 Like

OKAY, whew, here is what was going on, for your reference:

I use the Vivaldi browser, which runs on chromium so usually works with whatever works on chrome. My account was switched over to managed from direct, but I was not aware that I needed to reconnect my bank info (duh) and, here is the critical part: in vivaldi, the pop-up that says “you cannot add tiers until your account set up is complete” did NOT show up. And, when I went to my dashboard, nothing there told me I needed to complete set up either.

This morning, same thing. So just to check, I opened up a Chrome browser and tried again. This time, the pop-up appeared and so I knew what the problem actually was.

tl;dr: finished setting up account properly in Chrome, logged out, waited five minutes, then tried again to set up a tier in vivaldi, and BOOM it worked perfectly as designed.

Just posting this here in case anyone else has issues: try switching browsers. :smile:


Sorry for the delay–I also think I found a semi-workaround to the super slow character typing issue, which was hop on a different PC! I found it typed just fine on my Windows PC on brave browser, so I guess the issue must be something with my Mac, since it did it on both browsers I’d been using there. My Mac is my writing PC, though, so that’s not ideal on my end, but at least it’s working and I could update! It was still having issues saving and reverting tiers, though.

I’ll reach out through email, thanks.


I think I may have found the issue. I circled back with the technical team and will keep you posted :).

Very interesting. Great for us to know. I will test this out for myself so we can fix this! I’m very glad you found a solution though. So sorry for the trouble!

1 Like